My torque arm

Moderator: Moderators

Mopar 8.75" rear.

Postby Vega75randy » Tue Jun 05, 2007 10:05 pm

I did the same thing way back in 1981 before I was discharged from the Air Force. I had the 4 link taken off the stock rear end and reweld to the 8 3/4". I was into the Mopars just before I stopped building them around that time so I had lot's of spare parts. 3:91:1 Posi too bad I didn't have the 5 speed. I'm glad I traded it off for a 67 post Chevelle. The RPMs at hiway speed would have made cross country travel just short hops between gas stations. :lol:
Vega75randy
 
Posts: 105
Joined: Wed Jul 26, 2006 10:57 pm
Location: Venus, TX


Postby 10secvega » Thu Jun 07, 2007 9:34 pm

More pics of it installed.

Image

Image

Image

Image
Just a gold Vega with a little V-6

Image
10secvega
 
Posts: 407
Joined: Sat Apr 28, 2007 7:55 pm

Postby King Monza Mike » Sat Jun 23, 2007 4:20 pm

how hard does the car leave? 60ft's, boost off the line, etc?
All motor, stock suspension, small block, on a radial, daily driven, 10 second car, sucka!
King Monza Mike
 
Posts: 57
Joined: Thu Jun 21, 2007 9:34 pm
Location: Northern CA

Postby Kenova » Sat Jun 23, 2007 10:14 pm

I noticed you were able to mount the torque arm in the centre of the rear end housing and the front mount is beside the trans. Does the torque arm still run parallel with the driveshaft ? How much is the pinion offset on the Mopar 8 3/4?
It always amazed me how well the Mopar rears distributed torque to the rear tires, especially the peg leggers. Having the torque arm mounted in the centre of the housing should make it even better.
Ken
User avatar
Kenova
 
Posts: 1621
Joined: Sun Jul 02, 2006 9:46 pm
Location: Ontario, Canada

Postby 10secvega » Sun Jun 24, 2007 1:07 am

King Monza Mike wrote:how hard does the car leave? 60ft's, boost off the line, etc?

I try to leave with atleast 10 lbs of boost,best 60 ft with the v-6 has been a 1.56,car has been 1.51 with the old smallblock.
Just a gold Vega with a little V-6

Image
10secvega
 
Posts: 407
Joined: Sat Apr 28, 2007 7:55 pm

Postby 10secvega » Sun Jun 24, 2007 1:08 am

Kenova wrote:I noticed you were able to mount the torque arm in the centre of the rear end housing and the front mount is beside the trans. Does the torque arm still run parallel with the driveshaft ? How much is the pinion offset on the Mopar 8 3/4?
It always amazed me how well the Mopar rears distributed torque to the rear tires, especially the peg leggers. Having the torque arm mounted in the centre of the housing should make it even better.
Ken

The torque arm is very close by the housing then about a 1/2 inch away at tranny.
Just a gold Vega with a little V-6

Image
10secvega
 
Posts: 407
Joined: Sat Apr 28, 2007 7:55 pm

Previous

Return to Suspension, Steering, & Brakes Tech

Who is online

Users browsing this forum: No registered users and 1 guest