New old guy back with Drag Vega

Moderator: Moderators

New old guy back with Drag Vega

Postby BlackShadow » Fri Mar 25, 2016 4:25 pm

I picked up this 71 last spring. It now has a 388 with AFR 227 heads. I hoping to run a 6.2 in the 1/8th I can't seem to get the forum to work properly at them moment. The screen is black while I type. If I left click the screen comes back but my cursor is gone?? lolImage
BlackShadow
 
Posts: 7
Joined: Sat Feb 05, 2011 9:23 pm
Location: Rimbey Alberta Canada


Re: New old guy back with Drag Vega

Postby BlackShadow » Fri Mar 25, 2016 4:29 pm

This was my last Vega and the one I owned when I joined this forum. I had to sell it a couple years ago.
Image
BlackShadow
 
Posts: 7
Joined: Sat Feb 05, 2011 9:23 pm
Location: Rimbey Alberta Canada

Re: New old guy back with Drag Vega

Postby EVL VEGA » Fri Mar 25, 2016 5:01 pm

BlackShadow wrote:I picked up this 71 last spring. It now has a 388 with AFR 227 heads. I hoping to run a 6.2 in the 1/8th I can't seem to get the forum to work properly at them moment. The screen is black while I type. If I left click the screen comes back but my cursor is gone?? lol


Welcome! :burn:
I recently put AFR 210 heads on my 406 pump gas street motor. That 388 must breathe deep and rev high to need 227 heads!
EVL VEGA
'73 Vega Hatchback (former Super Gas car)
406 SBC, AFR 210 Eliminator Heads, 9:1 comp, pump gas, 328RWHP/412RWTQ (old heads, no N2O 1/17/04), 6.86 @ 100.8 in 1/8th (No N20 9/4/16), Mike's Trans TH400 (reverse manual), 5000 stall, 12 bolt, 35 spline strange axles, 4.33 gears, spool, hipster transbrake, linelock, backhalved, Alston 3 link, 100 shot NX Hitman+ kit, LC1 Wideband sensor, 31x18.5 MT Sportsman Pros, "Plum Ugly"™ Purple paint.
"Pound to fit..paint to match"
Image
User avatar
EVL VEGA
 
Posts: 209
Joined: Thu Oct 08, 2015 6:31 pm
Location: San Diego, CA

1973 Chevrolet Vega

Re: New old guy back with Drag Vega

Postby BlackShadow » Fri Mar 25, 2016 5:50 pm

EVL VEGA wrote:
BlackShadow wrote:I picked up this 71 last spring. It now has a 388 with AFR 227 heads. I hoping to run a 6.2 in the 1/8th I can't seem to get the forum to work properly at them moment. The screen is black while I type. If I left click the screen comes back but my cursor is gone?? lol


Welcome! :burn:
I recently put AFR 210 heads on my 406 pump gas street motor. That 388 must breathe deep and rev high to need 227 heads!

Yes, I shift it at 7200rpm. If you think that's bad when I bought it had a 12.5 to 1 355 in it with Max ported Brodix 11x heads and a 283/281@50 cam (not a typo) lol. That motor had to be shifted at over 7500rpm. 210s would have been fine but I found a smoking deal for the 227s and some day I'll build a 406-427 sbc for them. Thanks for the welcome.
BlackShadow
 
Posts: 7
Joined: Sat Feb 05, 2011 9:23 pm
Location: Rimbey Alberta Canada


Return to Drag Racing

Who is online

Users browsing this forum: No registered users and 1 guest