FrankenVega / FrankenCosworth

Tell everyone about the progress of your project! Please respect people's threads.

Moderator: Moderators

Re: FrankenVega / FrankenCosworth

Postby zeke » Mon Jul 13, 2020 8:34 pm

74_Vega_GT wrote:boy we need to start a wirring section saves time if all tog



There's one here already: viewforum.php?f=44
Chris

zeke's 79 Monza Project

zeke's 78 Sport Coupe

Photographs posted by this user (zeke) are the sole property of this poster. Any use without express written permission is prohibited
User avatar
zeke
 
Posts: 2892
Joined: Fri Jul 21, 2006 3:27 am
Location: Southern Ontario, Canada

1979 Chevrolet Monza 2+2


Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Mon Jul 13, 2020 10:58 pm

~...Sorry you misinterpreted the post, it was part of the "paste" , I am aware that we have an electrical section, and it must have been added sometime after that post which I copied and pasted was made.
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby zeke » Tue Jul 14, 2020 12:54 am

Ah gotcha lol :th:
Chris

zeke's 79 Monza Project

zeke's 78 Sport Coupe

Photographs posted by this user (zeke) are the sole property of this poster. Any use without express written permission is prohibited
User avatar
zeke
 
Posts: 2892
Joined: Fri Jul 21, 2006 3:27 am
Location: Southern Ontario, Canada

1979 Chevrolet Monza 2+2

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Wed Jul 22, 2020 4:47 pm

~ Blower fan circuit checks out OK
~ Both brake lights are working now.
~ Got a quote on 3D printing of the AC duct 74 to 77 transition piece at under 100.00. ...considering that.
~ I think the dash is ready for final fittment.
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Tue Aug 04, 2020 4:21 pm

~ Dammit Man--4 years now...sigh..at least my (2) supercharger clutch pulleys for the SRT-6 are out of quarrantine and made it to the USA. Fresh IHI Supercharger remanufactured should be here soon....Imagine that in a vega. lol
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby Monza Harry » Wed Aug 05, 2020 5:54 pm

'74 VGT Perfection takes time and yours is looking good keep us motivated with an endless stream of Pic's Please!
Oh a Blower will help with...well everything but fuel mileage and tire life, I somehow figure those will not matter much when the skinny pedal is pushed and Pushed HARD!
:th: :th: :th: Harry
I'm not a hoarder I'm a preservationist 78 Monza Spyder (~Soon(ish +/- I guess) To Be 2+2 with Spoilers)
User avatar
Monza Harry
 
Posts: 2544
Joined: Tue Oct 04, 2011 8:50 am
Location: Windsor ON Canada

1978 Chevrolet Monza 2+2

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Sat Nov 21, 2020 8:02 pm

_Back at it..
~ Got the emergency flashers working...Turn signals working, left front side marker is dim. Left front headlight is dim also. All blower speeds checked out as well as the low blower speed with key on.
~ Power at the brake light switch, both sides, ..no brake lights..horn works...Tachometer zeroe's out with key on so that checks out...no clock..no cigar ltr...orange wire is suspect.
~ Cluster harness connector, when the halves are separated, the orange wire has 12v...connected, it has 0 v. Jumped it out and the clock ran and the radio powered up...no smoke.
~ Alt light comes on with key on run position which checks out.
~ The volt meter, which I apparently assumed was a drop in replacement for the old amp gauge, will need to be re-visited.
~ We still have not started this motor yet until all of the electrical checks out.
~ If it was being built as a hot rod, we wouldn't need to go through all of this. If I was 30 yrs. old, it would go faster.
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Sun Dec 06, 2020 9:37 pm

~ Been studying this info...lots of turn signal questions in the Electrical section.

..by cosvega76 » Thu Jul 26, 2018 9:07 am
The turn signals gets power from the fuse on the fuse block between the RADIO and ELEC FUEL PUMP fuses (I thinks it's labeled GAUGES), which also powers the fuel gauge and idiot lights. This powers the flasher first then goes to the turn signal switch. The brake lights and hazards are powered on a separate circuit.
Chuck
cosvega76
Top

Re: 1972 Vega Turn Signals Operation?

Unread postby Monza Harry » Thu Jul 26, 2018 3:30 pm
The turn signal power goes through the connector on top of the steering column. Your symptoms sounds like the switch to me, but you said it was changed by you [bad new ones do happen] and the next thing I would check is to see if a prong from the earlier mentioned connector is pushed back and not making a good connection. This would mimic the switch problems and not be fixed by a new switch, unless you were looking at the right wire while plugging it back in you wouldn't notice that it moved, or if you looked at the terminals and noticed that the one was sitting back [not likely as it would be pulled forward from unplugging]. Harry

..........
So far--
~Dome light circuit checks out
~ Dim front left side marker - but bright with the Emergency flasher on.
~ No light from front right side marker - but bright with Emergency flasher on.
~ Dim instrument cluster illumination lights
~ Turn indicators-both-dim with no turn being called for when headlights are on
~ Horn works
~ Blower works
~ Brake light switch has power - no brake lights.
When everything checks out- we will prepare for an attempt to start the engine.
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Thu Dec 24, 2020 11:47 am

~OOps..going backwards- Couldnt see the illumination of the gauges in the dark, so, I should have used a lighter colored paint on the backside of the metal overlay which the factory had a "light blue" for a reason...to reflect the light to the face of the gauges, or so it seems. The plastic gauge carrier..where the gauges all inset into, also is this light blue...for the same reason, or so it seems. I had painted them a hot lime color, which aint gonna work out, I could have maybe used LED's to overcome the dimly illuminated gauge faces, but decided to re-paint it back to the light blue that GM used. Which meant disconnecting the main dash harness and radio connections and placing the assembly back on the work bench to disassemble...once more. I may hit the needle tips with bright orange again. Only the 2 gauge faces that I made, the tach and speedo, look fresh, the volt and temp and fuel gauges are a bit dingy. I never PhotoShopped those gauge faces as I did the tach and speedo. Now would be the time remedy that, but Santa has the Covid, so I am not looking for those in my stocking....
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby 79MonzaSpyder » Thu Dec 24, 2020 3:39 pm

On the gauges topic, I swapped my square body factory gauge cluster to LED a couple years back some pic's in this thread
viewtopic.php?f=44&t=46131 . I also just (last month) removed that cluster again and converted it to a factory tach setup and moved the fuel gauge to the lower left and modified the oil gauge back to a mechanical gauge from an electronic gauge. I got tired of replacing the electronic sending units which are prone to give inaccurate readings once they age. At the same time I bought some needle paint to paint my old gauge needles to match the new gas, oil and tach gauges I was putting in and ended up painting them all so they all matched. I would say you would see a great improvement with the LED lights and the needle paint makes everything look new. I bought several LED lights, different brands and styles, and tested them for fitment and luminosity and I found the ones I used and listed in the attached forum thread worked best for me and plan to try to use them on my upcoming Monza Build. The only thing with them is they are a bit longer than the stock incandescent bulb so you will want to make sure they will fit. Also If you don't know this already those bulbs only work when installed in one direction. i.e. if you pit it in and it does not light up simple take it out rotate it 180 degrees and re-insert it. It will work. Just saying since it would suck if you didn't check before you put the dash back in only to find a bunch are not working just because they were in backwards.
The Fleet
05 Toyota Camry SE V6
79 Chevrolet 3/4 ton Pickup Fully Restored with matching 78 11' Camper
80 Monza 2+2, Cloned into a 79 Monza Spyder V8 4 Speed (Current Project)
80 Monza Spyder V6 Auto (parts car, sadly)
80 Honda CB750K Fully Restored with Custom Full Dress
80 Honda CM400A 10,000 Orig. Miles Full Dress
75 Honda XL250 Fully Restored (first vehicle I ever owned)
73 Honda SL125 off roader
72 Honda Motorsport 250 (XL250) off roader
User avatar
79MonzaSpyder
 
Posts: 270
Joined: Sat Oct 07, 2017 5:28 pm
Location: Langley, B.C., Canada

1980 Chevrolet Monza 2+2

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Sun Jan 24, 2021 8:18 pm

~ Disconnected Engine Harness from firewall and polished and secured all brass connections on both sides and reconnected.
~ Disconnected Inst. Pan. Harness connector repeated polishing procedure above, both sides and reconnected. (Dremel wire wheel- polishing tips)
~ Tightened and secured loose pins in the I.P.harness which fixed an issue where we had to previously jumper around the connector with the pink wire to get power to the instruments.
~ Relocated the black and black w/wh wires formerly going to the Ammeter and supplied voltage from "F" terminal on Alt.to the black wire w/wh stripe and ground to the black wire so we could use the two wires already there to energize the Volt gauge. Battery is 12v but meter reads 8...AN ISSUE.
~ with Key -OFF, parking lights on, all the REAR markers are on and bright...good..front RT fender marker is OFF, front grill light on-LED-one row only...front Left fender marker shines DIM..front left grill light is normal brightness....KEY still OFF, pkg lights on...when you activate the right turn signal switch the the front Rt. fender marker, which was previously unlit lights up normal brightness. When you activate the left turn signal switch, the Lft. Frt.fender marker which was previously dim, is now normal brightness. The flasher unit will only flash with the key On which is normal.
~ I am guessing a problem at the steering column ground or, my guru says the turn signal switch is faulty.....it has had almost 50 birthdays. I reckon we can run separate grounds to them.
~ The stock ground for the entire instrument cluster lighting is relying on a tiny brass tang in the light switch connector with a light gauge wire that jumps off of the windshield washer connector. I upgraded this wire size on that jumper and made it separate from the light switch connector using a dremel cut wheel and made sure the connection was tight.
~ Onward we press...
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Sun Jan 31, 2021 10:45 am

~Purchased a new turn signal switch and a steering column spring compressor.
~ Studied the side marker and front turn signal schematics and compared them to the rear side markers and turn indicators. I found it strange that the rear side markers and turn indicators have their own separate grounds, where the fronts seem to get their ground at the headlight switch as well as the main ground on the driver side headlight.....still fighting it. I'm hoping the culprit is the harmonica connector on the column.
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Sat Feb 06, 2021 11:08 pm

~ Removed steering wheel on the tilt column to replace the turn signal switch.
~ Installed new switch and re-assembled the components for the wheel and horn button spring contacts.
~ Same pattern of dim side marker until turn switch is activated on driver side, no side marker on passenger side until turn switch is activated. All flash correctly with emergency flasher on.
~ Turn signals work properly with dash harness disconnected....of course no parking lights without dash.
~ All rear lights work properly.
~ Found these nuggets during my research to fix this issue, it seems as though many have had the same symptoms over the years....Thanks Spencer!
~.........by spencerforhire » Sat Jun 13, 2015 5:21 pm
If the fuse is good (if it is the rear tail lights will still be working),The side marker lights still work because they are wired between the park and signal circuits. When the park lights are on, they are supposed to light up because they can get ground from the signal circuit. When the signals are on, the side markers flash with them if the park lights are off, and opposite the signals with the park lights off.
..................
spencerforhire » Sat Jun 13, 2015 5:25 pm
Time to get in there with a meter or test light and check the brown wire where it comes out under the hood at the bulkhead connector.
....................
spencerforhire » Mon Jun 15, 2015 7:07 am
There is a 3 or 4 way splice somewhere in the harness behind the left headlight where the brown wire splits off to the light under the bumper, the side marker and the passenger's side.
~ All of these tests were done with the steering column hanging...not sure how much ground the column being bolted in place would add. We tested 8.5 V on one of the blue wires without the turn switch being engaged.....And it continues...
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Fri Feb 12, 2021 10:24 am

~Lots of good info on the turn signal switch posted over the years. Many of the symptoms that I am having have been addressed in the past. A search for the word "flasher" turned up a lot of info I need to digest. I see where people are preferring a "solid state" flasher. This might be my problem. I'm on it today....somewhat, it is Friday you know.
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

Re: FrankenVega / FrankenCosworth

Postby 74_Vega_GT » Fri Feb 12, 2021 1:16 pm

~ Found a heavy duty flasher unit on the fuse block, a modern one, and an old school style flasher unit on the pigtail. Reseated the pigtail and replaced the one on the fuse block with a std. duty unit.
~ Replaced blown "guages" (again?) fuse.30A
~ Performed a smoke test--
~Parking lights-(fr.side mkrs.)-fixed- no more dim
~ Turn signals - no more dim dash indicators - turn indicators blink bright and properly now - front and back.
~ Emergency flashers - bright, work properly..(they always did).
~ Headlights - Brights work properly - blue dash indicator works--- No Low Beams..no smoke either.
~~(An old instructor once said that: "Everything electrical runs off of smoke, if you don't believe me, let the smoke out of an electrical item and see if it still runs.")
~ I'll check the bulb......Motor startup procedures should start soon after we verify power at the coil wire.
>I Love the H-Body forum and am grateful for it and all its members contributions, disclaimer below is directed at search engines.
> Photographs posted by this user (74_Vega_GT) are the sole property of this poster. Any use without express written permission is prohibited.
1974 Chevy Vega GT Hatchback
1982 Chevy S-10 longbed 2.8v6 A/C
2005 Chrysler Crossfire SRT-6 Coupe,Black
2005 Chrysler Crossfire SRT-6 Coupe,Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Silver Sapphire Blue
2005 Chrysler Crossfire Roadster N.A., Aero-Blue
2008 Dodge Ram Longbed, Brilliant Crystal Pearl Black
74_Vega_GT
 
Posts: 449
Joined: Thu Jun 16, 2016 2:40 pm
Location: Central Florida

PreviousNext

Return to Project Journals

Who is online

Users browsing this forum: No registered users and 1 guest