Blower motor relay

Moderator: Moderators

Blower motor relay

Postby meschnebly » Sun Sep 11, 2016 7:23 pm

My fan works on low, med, med high but not on high. Think it could be the blower motor relay that's mounted on the outside of the fan housing under the hood? '77 Monza 2+2 V8.
I've traced wires until I'm bushed (doesn't take much for an old fart) and that seems to be an unknown.
meschnebly
 
Posts: 74
Joined: Sun Sep 10, 2006 3:43 pm


Re: Blower motor relay

Postby meschnebly » Mon Sep 12, 2016 9:49 pm

Well, that relay is cheap so I guess I'll just swap it out and see.
meschnebly
 
Posts: 74
Joined: Sun Sep 10, 2006 3:43 pm

Re: Blower motor relay

Postby Monza Harry » Tue Sep 13, 2016 7:11 pm

Mes' did you do any multi meter tests? Voltage at the switch before and after, at the blower itself? To really help we will need some blanks filled in. The wiring on the non A/C is pretty simple I don't recall any relays for that, now A/C that is a different kettle of fish! Harry
I'm not a hoarder I'm a preservationist 78 Monza Spyder (Soon To Be 2+2 with Spoilers)
User avatar
Monza Harry
 
Posts: 2113
Joined: Tue Oct 04, 2011 8:50 am
Location: Windsor ON Canada

1978 Chevrolet Monza 2+2

Re: Blower motor relay

Postby meschnebly » Fri Sep 16, 2016 2:06 pm

Sorry, been stuck working.
Well, it used to be an AC car but it's removed. I'm doing more voltage testing this weekend. this is a similar pic of the relay and it's mounted in the engine bay on the heater fan box. I've got one coming today as the one on there is super corroded. It's cheap so what the heck. After this weekend I'll get back on and let you know what I find. Hope voltage tracing or the relay leads me to the problem. Parking lights and all other lights work so I know the 12V is getting to the switch so I'll follow it to the dimmer and out from there next.
Attachments
relay.jpg
relay.jpg (26.06 KiB) Viewed 246 times
meschnebly
 
Posts: 74
Joined: Sun Sep 10, 2006 3:43 pm

Re: Blower motor relay

Postby meschnebly » Mon Sep 19, 2016 8:50 am

Well, new relay didn't fix it so when I get some time I'll start tracing wires from the switch and go from there. Almost got it ready for the exhaust this week so I'm coming to the end of the road with the rebuild.
meschnebly
 
Posts: 74
Joined: Sun Sep 10, 2006 3:43 pm

Re: Blower motor relay

Postby stage169 » Mon Sep 19, 2016 12:06 pm

If you have time check this post out. viewtopic.php?f=44&t=44075
Image
User avatar
stage169
 
Posts: 1702
Joined: Tue Jun 27, 2006 11:43 pm

Re: Blower motor relay

Postby SeniorSavage » Mon Sep 19, 2016 4:06 pm

generally, if it works at some speeds and not another (like your High speed here) its a fried resistor in the resistor pack .. one of them has overheated and is fried.

http://www.samarins.com/glossary/blower ... istor.html

https://www.youtube.com/watch?v=hgar6Q1lV6A

http://www.youfixcars.com/blower-motor.html

https://www.youtube.com/watch?v=UJ-MfAo8AUQ

https://www.ericthecarguy.com/faq/solvi ... ms?start=7

https://www.cargurus.com/Cars/Discussio ... 2_ds569146

good luck, Sav
The fleet;
1975 Buick Skyhawk 3.8 V6 turbo - total restore ongoing (soon!)
1980 Buick Riviera 5.7 Olds 350 Rocket - restored daily driver
1984 GMC G30 5.7 350 Chevy sbc 20' Okanagan motorhome - for tight spots
1996 Fleetwood Bounder 35' Ford 460 TBI motorhome - for not-so-tight spots
2004 Harley-Davidson Heritage Classic 88ci 1450cc. - custom original.
2007 Ford Escape XLT 3.0 V6 AWD (wifes truck) - working original.
User avatar
SeniorSavage
 
Posts: 369
Joined: Mon May 07, 2012 2:00 am
Location: Vancouver Island BC Canada

1975 Buick Skyhawk

Re: Blower motor relay

Postby stage169 » Mon Sep 19, 2016 5:37 pm

It might be simpler to make your voltage checks at your new relay. Since your fan is working at the lower three speeds then your resistor pack is good. Looks like High speed uses the relay and does not go through a resistor.

With your fan switch in High see if there is voltage at the plug for the relay - orange wire 86 (looks like the middle two should be the coil). If it does have voltage then the relay is turning on and I would guess that there is no power at 87 (red wire) and that is why your high speed is not working (fuse link).

If the plug for the relay doesn't have voltage then there is probably a problem with your blower switch.

Of course I'm making assumptions here and if Zeke's schematic is wrong then it is his fault :D But I trust him, it looks good!
Attachments
hbody_blower_schematic.jpg
hbody_blower_schematic.jpg (108.52 KiB) Viewed 218 times
Image
User avatar
stage169
 
Posts: 1702
Joined: Tue Jun 27, 2006 11:43 pm

Re: Blower motor relay

Postby Monza Harry » Tue Sep 20, 2016 6:24 pm

stage169 wrote: Zeke's schematic is wrong then it is his fault :D But I trust him, it looks good!
Zeke while your under the bus can you check the right rear brake it seems to be a little grabby! :lol: I think you may have a switch problem as well. Most likely I feel. Harry
I'm not a hoarder I'm a preservationist 78 Monza Spyder (Soon To Be 2+2 with Spoilers)
User avatar
Monza Harry
 
Posts: 2113
Joined: Tue Oct 04, 2011 8:50 am
Location: Windsor ON Canada

1978 Chevrolet Monza 2+2

Re: Blower motor relay

Postby meschnebly » Mon Oct 10, 2016 5:29 pm

Thanks, I replaced the relay and that didnt fix it so I'll check out the switch next. I appreciate the drawing too!!
meschnebly
 
Posts: 74
Joined: Sun Sep 10, 2006 3:43 pm

Re: Blower motor relay

Postby spencerforhire » Tue Oct 11, 2016 1:15 am

None of my h-bodies have had A/C, so I can only go by the schematic. But my money is on the fusible link; easy to prove with a meter or test light.
The "fleet"-
77 Vega Estate wagon- project(someday)will have TPI305/T-5, S-10 spindles/axles
72 Vega HB Drag Car -383/'Glide/9"(9.45@146.19)(6.01@117.28 1/8th)
76 Vega GT- 400/4spd/9" retired from active duty(rusty)
03 Silverado 2WD ex.cab (work truck/parts hauler)
04 Silverado 2WD ex.cab (retired)
06 Haulin' 20ft enclosed car transporter
93 Suburban- 350/4L60(retired)
00 Saturn SW2- wife's car
01 Saturn SC2- younger son's project
00 Saturn SL2- daughter's car
98 Saturn SW2- spare
and 3 more Saturn "parts cars"
Note- the very act of listing all of these has made me realize I have some kind of problem.....

Visit http://www.spencerforhire.ca
User avatar
spencerforhire
 
Posts: 2371
Joined: Mon Jul 03, 2006 9:02 pm
Location: Halifax, Nova Scotia

1972 Chevrolet Vega Hatchback

Re: Blower motor relay

Postby zeke » Wed Nov 16, 2016 7:12 pm

My gawd that's a horrible drawing! :lol:
User avatar
zeke
 
Posts: 2234
Joined: Fri Jul 21, 2006 3:27 am
Location: Southern Ontario, Canada

1979 Chevrolet Monza 2+2


Return to Electrical and Wiring

Who is online

Users browsing this forum: No registered users and 1 guest