1973 Vega Bulb Lighting Question

Moderator: Moderators

1973 Vega Bulb Lighting Question

Postby TheSpectre » Wed Sep 06, 2017 7:43 am

Hello all, new guy here. I need some of yall's help. I'm trying to get the illumination bulb for the instrument panel working because as of right now, when I turn the headlights on the only bulb that illuminates is the right turn signal (this also happens when I turn the hazards on), however the right and left turn signal both function when they are switched from on from the turn signal switch so I am at a loss.

My second issue is when I turn my headlights on, all the proper outside lights function except the passenger side turn signal, and passenger side front marker light. However both of these lights do function when the hazard lights come on, so again. I'm at a loss.

Thanks for any help.
TheSpectre
 
Posts: 3
Joined: Tue Sep 05, 2017 10:51 pm


Re: 1973 Vega Bulb Lighting Question

Postby cosvega76 » Wed Sep 06, 2017 8:39 am

Sounds like you're missing the ground for the RH turn signal. It's grounding through the indicator on the dash, which is why the indicator is on.

Chuck
cosvega76
 
Posts: 2385
Joined: Mon Jul 03, 2006 8:36 am
Location: Moscow Mills, MO

1973 Chevrolet Vega GT

Re: 1973 Vega Bulb Lighting Question

Postby TheSpectre » Wed Sep 06, 2017 3:37 pm

You believe that my right hand turn signal is missing the ground? I would first like to know where the ground cable is so I can attempt to fix it. Secondly I wanted to know why the right hand turn signal ground is preventing the left hand signal from functioning when the hazards and lights are on.

The opinions of others state that I have a bad ground wire somewhere. Where would I go about finding these on a 1973 Vega. Thanks guys.
TheSpectre
 
Posts: 3
Joined: Tue Sep 05, 2017 10:51 pm

Re: 1973 Vega Bulb Lighting Question

Postby TheSpectre » Wed Sep 06, 2017 11:05 pm

Alright yall. A little update after working on the car this evening. The passenger side front turn signal, and front side marker light, and rear side marker light do. It come on with the headlights because they aren't grounded to anything. On that side only the headlight is connected to a ground, hence why it functions. I replaced the 194 bulb in the turn signal (in the instrument panel) with a 168 and now it flashes when the hazard lights are on just like the right hand turn signal. The part I couldn't figure out is when I turn the headlights on, the left hand turn signal (in the instrument panel) still doesn't illuminate, however the other three bulbs do. So I still need to figure that one out. Additionally I still don't understand how the passenger side front turn signal and front side marker side function with the hazard lights on but don't function when the headlights are on. I understand they aren't grounded but it still works under one circumstance and not the other. Thanks for yall's help and any further assistance.
TheSpectre
 
Posts: 3
Joined: Tue Sep 05, 2017 10:51 pm

Re: 1973 Vega Bulb Lighting Question

Postby dindin » Thu Sep 07, 2017 5:06 pm

Don't know whats causing this, but on my 75 it has 2 grounds under the hood, one on the left side of engine bay and the other on right side in the front corners, they come off the harness that feeds the lights

..sometimes a bad ground can cause funky things to happen.

Al
dindin
 
Posts: 439
Joined: Wed May 21, 2014 10:01 am


Return to Electrical and Wiring

Who is online

Users browsing this forum: No registered users and 1 guest