Turn Signals, and Dash Lights Inop.?

Moderator: Moderators

Turn Signals, and Dash Lights Inop.?

Postby 29EssexRat » Tue Jul 24, 2018 1:29 am

1972 Chevy Vega

Bought this car, was an ex drag car. 90% of the wiring is still there, just the whole car was gutted. There are some cut wires, I have repaired some, a couple lead to no where, as in, can't find the other end, others the wires are cut right at the "connector block".

Problem are as followed:
- The turn signal switch does not work. The hazards switch does work.
- I have no dash lights, as in the backlighting, the turn signals (with the hazards) work, and the blue light for high beams works too.

I have replaced the turn signal switch. The hazards work. The running lights/headlights/brake lights all work.

Is there a separate flasher relay for the turn signals? If so, can anyone take a picture of the connector and wires.

Is there a common ground for the dash? If so, where?

Also, this may be a dumb question. But the wiper blade button. How do you operate it? It has a "Push" button, and a slide. I see you can slide the slide switch in three positions. I presume Off, Low, and High for wiper speeds. Then the push button. I push that in and it stays in, and moves the slide button to the Low position. But now I cannot move the slide back to the off position. Well I can, but I have to grab the push button with a pair of pliers and pull it out, then move the slide to the Off posistion. Obviously this is incorrect operation, but wondering if I'm just being dumb, or if my switch is broken.
29EssexRat
 
Posts: 5
Joined: Mon Jul 23, 2018 2:35 am


Re: Turn Signals, and Dash Lights Inop.?

Postby cosvega76 » Tue Jul 24, 2018 9:10 am

Yes, there is a separate flasher for the turn signals. The two-prong connector is under the dash, with a clip for the flasher, to the left of the steering column.

Do the tail lights work? IIRC, the dash lights and tail lights use the same fuse. I'm assuming that rotating the headlight knob doesn't change the dash lights. It could be a defective headlight switch, also.

If you have the factory wiper switch, it should have a separate washer button. That is actually a manual washer pump on the backside of the switch, each push on the button would make the washers squirt once. It sounds like either the spring is broken, or the entire pump is missing.


Chuck
cosvega76
 
Posts: 2512
Joined: Mon Jul 03, 2006 8:36 am
Location: Moscow Mills, MO

1973 Chevrolet Vega GT

Re: Turn Signals, and Dash Lights Inop.?

Postby 29EssexRat » Tue Jul 24, 2018 2:54 pm

Ok, I ended up getting the dash lights to work, connector wasn't plugged in all the way. I also found the flasher relay connector, i used the relay from the hazards and still no turn signals.
All the lights work, hazards work, just the turn signal switch isn't.
And yeah I'm missing all of the wiper stuff.
29EssexRat
 
Posts: 5
Joined: Mon Jul 23, 2018 2:35 am


Return to Electrical and Wiring

Who is online

Users browsing this forum: No registered users and 1 guest